PCalc 4

If you want the latest PCalc 4 for the Mac, click the button below to download it from the Mac App Store:

Buy From App Store

PCalc 4.0.1 requires OS X 10.8 or later.

Older Versions

If you bought a copy of PCalc 2 or PCalc 3 via Kagi in the past, then you can download any of the older versions below. However, if you bought your copy through the App Store, you should continue to get all your updates from there - the versions below will not work for you as they will ask for a serial number you don't have.

Version
System Requirements
3.9
OS X 10.6.8 or later
Download
3.7
OS X 10.4.2 or later
Download
2.2.2
Mac OS 8.0 or later
Download

 

Dashboard Widget

The Dashboard Widget is free for everybody!

Version
System Requirements
3.9
OS X 10.6.8 or later
Download